Discussions from our smallest wikis are found here! Check the Wiki Hub for details
 
Avatar

FextraBot

Town Crier
Joined: Tue Nov 12, 2013 6:27 am
Souls: 0.00
Posts: 24357
Reputation: 12
These are cross-posted comments on a wiki page. You can visit the page here.  Read Wiki Page

The information about the Flooded Area is wrong and should be changed. August is actually in the Sunken Queen Anne's Revenge, near the chest with the chandelier, not in either of the Sunken Mary Rose locations. I spent 20 minutes searching before I tried other locations.
where is the Sunken Queen Anne's Revenge?
I couldn't find him in sunken mary rose. There are only 2 sunken mary rose entrances. one with save point and one with hand of glory, but couldn't find August. Help?
the wiki is wrong. He's in the other named ship, something revenge. its the one that has the wooden diagonal gate that doesnt open from the outside. go to the left of that ship and drop down, then go right. he's in there.
Where's his location in mine? I couldn't find him. And where can I get antidote?
I've literally been looking for over an hour and can not find his mine location. I detailed the entire mine, so maybe if you do them out of order he doesn't show up in the mine? I don't know, but I'm done looking.
Also I don't know why the game says antidote. Both times I found him poisoned he needed vinegar not an antidote. I've been playing for 23 hours and haven't come across anything called an antidote.
in the mine he is in the bottom west part of the map where all the moving platforms are.
I can't find him in the sewers. I've found him in all the other locations, but no sign of him in the sewers. Any help?
Where did you find him in the mine?
I can’t find him in the mine! Any help
I've been exploring the moving platform area in mine (red area in map) but still nowhere to find him
I spent more then 2 hr inside mine but still not find him...please any advice?
Found him in the flooded town, the lake, and then the sewers. Still can’t find him in the mine at the location he’s said to be even though it should be the last location.
I think he’s glitched in the mines, so he isn’t showing up