Discussions from our smallest wikis are found here! Check the Wiki Hub for details
By Anonymous
Just got here in the Remake. Right when I was about to get the key I was summoned - game glitched and I lost the key for this playthrough! Note to self/all, clear your summon sign before engaging in one-off NPC events like this... Blargh!!
By Anonymous
I ran past him to fight the invader that’s right after him and died, came back and now he’s no longer there and I have no key this play through.
By Anonymous
100% Rescued Ostrava in 1-1,1-2, and 1-3... but when I got to 1-4, he was not on stairs, and only BP was on bridge to elevator. WTH?!... sigh... guess no key this playthrough.
By Anonymous
same here
By Anonymous
Same here, my playthrough is ruined because of bug bluepoint doesn't give f about..
By Anonymous
I saved him aswell, and confronted his BP at the bridge. I killed him and got the sword and shield, BUT when I went into the room behind him, someone dropped behind me and there was the key. It was super weird, but oh well, I didn't know what this key does, so I didn't use it.

TLDR: weird stuff happened - maybe they fixed it in the end. Kinda.
By Anonymous
This is the most bs enemy in fromsoftware games, he oneshots you with every attack and has stupid amount of chunky spongy health. He got like what, millions of hp? And I can only deal about 90 damage per hit, **** whoever made this boss.
By Anonymous
You're not supposed to kill him you dope he's a king that's human he's testing your skill and obviously aren't good enough
By Anonymous
I absolutely destroyed this guy and flamelurker. Demolished them. But satauki took me hours. Crazy.