Discuss Divinity Original Sin, as well as comments posted to our Divinity Original Sin Wiki and Divinity Original Sin 2 Wiki


Town Crier
Joined: Tue Nov 12, 2013 6:27 am
Souls: 0.00
Posts: 28631
Reputation: 12
These are cross-posted comments on a wiki page. You can visit the page here.  Read Wiki Page

You can just teleport to waypoint to save him.

I was fairly surprised when it worked.
Of course you can try to cheese by teleporting him, but that's the "fun" usually cheaters/exploiters see.
Using the skills you've acquired to solve challenges in a different way is not cheese or cheating. It's doltish not to use it. Wtf is wrong with people. Teleportation is not a bug or an exploit. It's a skill I spent points on. What kind of idiot mage would say 'Gee I have teleportation, but I think we should try to walk past everyone anyway'? It's an RPG, play your role.
Translation: "I got stuck at this part for a long time and didn't realize you could teleport out, so now I have to trash people who adapt and overcome using the tools provided by the game."
Or you can use pyramid to teleport out of the city.
I killed three magisters with some careful plays and got him out no issue. Once a magister sees him they chase him all the way to contact distance BEFORE combat starts, so you can kite them somewhere nice and quite for a little of the ole ultra-violence... Hope that one doesn't come back to bite me in the ***.
Tried using the teleport pyramids |AND waypoint travel, higba stays behind each time...
I teleported to Lady Vengeance and he wasn't there. However, I clicked on the boat to return to the coast and he appeared, then he jumped into his barrel and quest completed.
I turned him in and got some good weapons from his corpse :P


Joined: Sun Jan 14, 2018 10:54 am
Souls: 50.00
Posts: 1
Reputation: 0
So after having talked to both Higba first and then the magisters who are searching for him, escorting him out of the city, ending the quest by letting him go and THEN turning on him by attacking him my red prince somehow got the hero tag ( he had villain already).
My first play through I was able to teleport to lady veagence. They must have patched this because it's not working now
After you save him for the quest reward, if you have stolen his grenades and attack him, he starts attacking and then wonders "where are my grenades?"
Why I can't see stolen icon? Is this patched?