Comments made to our Lords of the Fallen Wiki
 4 
 
playing on xbox one and every time I land the killing blow on kyle embers ghost my game freezes. My roommate is playing on the same disc and killed him just fine a couple days ago. Disc is free of physical damage and it only seems to happen here. Anyone else having this issue or know of a fix?
I wanted initially to play rogue, however the staff and griffin armor are so cool..... problem is i am credited 84 armor for the full set (should be 129 armor with the runes i put in there....) how so the total armor in the "armor" section on the botom left corner is not correct?
i've completed the injured monk's questline, given him 10 tryant hearts, but he does not upgrade my potion -_-
VIP
Avatar

Fexelea

Webmistress
Webmistress

Fire Keeper

Joined: Mon Jan 16, 2012 10:00 pm
Location: Japan
Souls: 440,062.49
Bank: 10,404.71
Posts: 13678
Reputation: 759
Wiki Edits: 39471
This one is new... :S
Fextralife: Gaming News ⚔️ Sekiro Wiki ⚔️ Monster Hunter World Wiki
A gaming blog and wiki network powered by real gamers.
Shop IconShop IconShop IconShop IconShop IconShop IconShop IconShop IconShop Icon
During combat, while dual wielding daggers, my audio cuts out completely with one exception... Harkyn's heavy breathing.
O.o
I'm having the same issue on Ps4 although it will just happen randomly in a save and doesn't come back :/
For no apparent reason, my character's magic regen rate is slower than heck. I finished NG on Slot 1, then decided to start a fresh character on Slot 2. Got him up to 27 Faith, but his regen from empty to full takes about 80 seconds (55 with Faithful Disciple). I started to wonder if maybe Slot 1 was bugged and had way faster regen than he should, so I reinstalled it on PC (finished it last year, so my memory was hazy) to find that my character there had magic regeneration comparable to Slot 1 on PS4.

I only just finished Worshiper and his dimensional portal, so I haven't reached Greed, which I know has been responsible for magic problems.

Anyhow, filled Slot 3 with a character and got his Faith to 22, but he still has a horrible regen rate. Such a bummer. Tried swapping out all gear, quitting to title, rebooting the game, but nothing works.
I have yet founded kaslo at the start, and game continues to say :Found Kaslo.
How to resolve?
The game keeps crashing during the beast boss fight. Anyone else had this?
Same here have tried six times so far on ps4 and it usually crashes like a minute into the fight.
Same here tried 3 times been looking for a way to fix it nothing yet :\ just got the game from psn and Saints row and thats crashed twice DON'T BY***** FROM PSN THEY CLEARLY SCAMMING PEOPLE BY SELLING THEM GAMES SUPER CHEAP THAT CONSTANTLY CRASH
Confirmados:
Armando
Vitor "kj"
Armínio
Carlitos
Arthur
Ian
Ignore the anterior post.
Well, I wanted the epic weapon from the annihilator but I forgot to kill him with an electric weapon, so I restarted the game, but at my second try, I died. Suddenly (I already saved the game), I was recieving way too much damage from electricity (ghost one shoted me) but i tried to fight the boss, and he killed me with any single hit. I tried everything to solve the problem, but I couldn't, so I killed the boss without getting any damage. But now I have to fight the twin brothers, and I die way to easy. Somebody help me, please
I became invincible and invisible to enemies due to a bug. I was running past a bunch of enemies to get to my ghost ( seldom works out well) in the Rhogar's realm part.

I ran down the stairs near where the first weird dragon-like creature and a forger are and attempted to open the first small gate you come to. I was getting attacked by multiple enemies but when the gate opening animation triggered they suddenly left.

I thought I had just gotten lucky and seeing my health bar was empty, I drank a potion. My health bar remained empty. So I drank another. Still empty.

At this point I suspected I must have hit a bug so I walked back out of the small room. None of the enemies responded to me but I was still able to attack them. Clearly as far as the game was concerned I was dead.

I also discovered that I could no longer interact with objects. No prompt showed on shards. I didn't try leaving an area or interacting with any other doors but I suspect the same would apply.

Unfortunately I discovered that falling, even from a small height killed me. Thinking about it that makes sense since it's not like the ground needs to detect you.

I suspect that any door would work for this but the chances of timing it so an enemy drains your last health just as the door animation triggers seem pretty low!