Comments posted to our Dark Souls 3 Wiki
1 
 
Avatar

FextraBot

Town Crier
Joined: Tue Nov 12, 2013 6:27 am
Souls: 0.00
Posts: 9662
Reputation: 1
These are cross-posted comments on a wiki page. You can visit the page here.  Read Wiki Page

Darksouls3fan1

Joined: Wed Mar 23, 2016 7:33 am
Souls: 50.00
Posts: 2
Reputation: 0
Why cant' Dark Souls 3 come out earlier?
Because like the japanese withe there games like to allow there people to play for a wile before us thats what i sometimes think but they do have to make english vertions of the game to and then ship them to the shops witch take time and the shops also got to put them out awell but i get what you are on about.
I like everything about this post
^
:(
Where the ***** is my game? it came out last month and i still cant play it? i will sue bandai namc for this *****.
pls do and keep us updated
Good to see by the time us laymen can play most of the gamebreaking bugs might be fixed.
Oh please let the time pass very fast, till I get my collector's edition..............
Hey man were almost there. Couple more days may you pass very fast.

Introduced a function so that the Fire Keeper and Velka, Goddess of Sin may return the player to life form.
Indeed... it's out topic, but, the fact that they put new things like this give me hope to see back a particular features that was in "Dark Souls 2" : the ability to use our weapons with full capacity, whether you play right-handed or left-handed...

'Cause so far, I heard that it was like in dark souls 1 : left weapon only do simple attacks and a shield action... but is it true ?
hazza it out praise it \[T]/
cant download updates on Xbox please help
for some reason AMD processors are glitching the game so that i can NOT hi the actual model of an enemy unit nor can it hit me i can however hit its spawn point, you know this could be easily solved by me buying i5 processor and 1155socket motherboard but i dont have 1k EURO... so please fix it as fast as possible
I'm having the same problem. A lot of people say it's related to having an APU on your core or something. I don't fully understand it, but I tried disabling the APU in the BIOS. Didn't work.
sry but that is not the case for me, i have an FX 8350 and it works perfectly.... (nvidia geforce gtx 980 Ti by msi though)