All discussions related to the PC version.
By Caccio72
#701838
Greetings!
Someone PLEASE help me with this matter, since it's literarilly driving me crazy already!!!
Whatever I do, however I remap the run and jump key command, whatever combinations of them I use, my character just WON'T jump at all!
Yes, I know this problem was brought up here before, and I read all the answers and suggestions I could find, tried each of them, but NO, I still cannot jump!
Dark Souls 2 itself looks really great, its controlling method and UI is also much more "user-friendly" than in the 1st part, so it could finally provide me a unique experience and fun i always desired, other than just running around hack/slashing weak and dumb AI enemies, but without solving this jumping problem I stopped playing it soon after creating my character, since jumping is a move which I often use in similar games, both during combat and movement, so making it to work is essential for my proper game experience.
Here are the things I tried so far, following hints, suggestions, and advices found while Googling:

Remapping-reassigning both run direction and jump keys and commands (of course I tried without reassigning a single key or coommand too)
Using all kinds of combinations of those commands while playing
Holding "run", then pressing it rapidly right after a sudden stop
Pressing both "run" and "jump" keys rapidly before, and while moving
Updating the game to a newer version (in case of version-related bug)
Restarting with a new character class with light armor (originally I choose Knight)
Taking off even my remaining armor, (in case the gear is still too heavy for jumping)
Tried Jumping on the very start, before character creation, then as a "Hollow" even

And still, I havent managed to o one single jump by now......PLEASE tell me, what the heck am I doing wrong???
Or is it possible that my character doesn't "know" how to jump in the starting phase of the game, and has got to learn it yet?
I highly doubt that could be the issue, since I am already able to easily perform ALL OTHER movement and combat commands, the only one exception is jumping......
By LunaAstoria
Posts
#701894
Are you sprinting when you hit the jump button? You can't just jump in dark souls, you have to be sprinting. For example, on the ps3 I have to hold O while moving to Sprint and (while moving) click the right stick to jump.

If I had to guess, you're trying to jump like you can in say skyrim. Just tapping the button and up you go. That's not the case in dark souls. You can't just jump up and down, you have to be moving.
By Caccio72
#701948
I did read in Google suggestions that I have to "run" before, and when jumping, so I am of course doing it by each of my tries.
But "sprint"?
You confused me with this one a bit, since I know in some games, above to "run", there is also a "sprint" command, which makes the character moving even faster than by running. (like in DayZ type games or Skyrim itself for example)
However, I don't know about such a command existing in Dark Souls 2......
User avatar
By announakis
Posts Avatar
#701965
no there is no sprinting being faster than running in DS2.

maintain O or B I believe on Xbox/PC (the dodge button) down while moving to run...release and press promptly the same button to jump.
By default the jump action is mapped to the analog left (or right not sure) stick in DS2...I cannot stand this so I mapped it back to DeS DkS configuraiton...you have the option...maybe you wanna check that this option is ticked to your preference because if you try to do it by pressing the dodge button but the preference is set to using the analog stick you can try forever....sounds like this might be your problem.

if this sounds like it might be it, go to options ==> you should find it under one of the tabs fairly easily.
By Caccio72
#701973
When i use the dodge/roll key, (while running), I manage to perform a forward roll, but as I read, that is not supposed to be the same as JUMPING.
If it would be, that would hurt the game realism a but, after all in RL we can all just simply jump in the air, or jump forward, with or without rolling......

As for that analog stick setting, I shall check it out right now, this really MIGHT be the solution, THANKS!

EDIT:
I just found the setting you mentioned, and set it to B, then kept remapping and trying out the jump controls, (including the B key itself), ......but still the only thing I can do is that forward roll. (with the dodge command)
Besides, there IS a specific "jump" command I can assign keys to, that one doesn't function at all either, (normally tried ot wile running), no matter what key I assign to it.
The same counts for mouse controls too in the game, there I also have a "jump" command, but when i set it for example to middle mouse button click, nothing happens either.
So actually no matter what jumo command I combine with runnung, (including rapidly pressing/combining the "run" command with itself), nothing happens, except forward roll with the use of "dodge/roll" key.
I am starting to become totally clueless......
User avatar
By announakis
Posts Avatar
#701987
wow...this might a completely bugged version of the game that you have because...I cannot figure out any other reason.
sorry
By Caccio72
#701990
YESSS......it seems I finally managed to find a type of solution, even if I highly doubt it is the proper, originally planned one:
Now I am able to perform smaller forward jumps, using the jump key (or command) while running, BUT ONLY when the "auto-dash" command is active.
Those forward jumps are often, but not always followed by an additional roll as well. (probably caused by the active auto-dash function)
Dashes and rolls are also functioning normally with their command key this way.
However, without activating auto-dash I still cannot jump at all, I can only do forward rolls, simple dashes and backsteps. (by using the dash/backstep/roll key)
Should this be the proper solution, or I am still have the wrong setup?
If this should be how the game works, is wish to know if there is a possibility to set auto-dashing on by default, so i wouldn't have to set it manually after each game-start?
(I couldn't find such an option or setting in the game so far)
By Caccio72
#702004
I finally realized what the PC version is all about:
There are not 2, but actually 3 movement modes, walking, running and dashing.
You are allowed to jump ONLY while dashing. (and I mean dashing, not simply running)

So in order to jump, you have 2 solutions:
1. Either activate the auto-dash command 1st, then while running simply press the jump key (that's the easier way, which I figured out first)
2. Or while "normally" running, (so without using auto-dash), press the dash and then the jump key. (since you obviously must dash in order to jump)

The 2nd option is obviously harder, and more complicated to perform than the 1st one, but unless we want our character to keep constantly dashing during its movement, we just HAVE to use this solution......it seems.

Once again, game producers/developers neglected and slap-dashed the PC version for the benefit of those game-consols, which the game was originally made for. (not the 1st, and probably not the last time this happens)
:(
User avatar
By announakis
Posts Avatar
#702170
good on you m8
By EMITE
#738673
Maybe someone had another problem same as mine. I can't jump also. But my issue is more complicated i think. When i'm using keyboard button everything seem to be fine. Problem is with controler (wireless X360). I know the controls so i'm dashing and trying to rapidly hit B button to jump but my character does roll. Every other controls are working. I can run/dash light/heavy attack but simply can't jump. Maybe some of you have had same issues and found a solution? I'd be glad for every single advice.

EDIT: oh one more thing. This happens only in SOTFS. I have base DS2 also and everything works perfectly fine there.

Cheers