All discussions related to the PC version.
Reply  

Gorf

Joined: Fri Jun 24, 2016 6:51 pm
Souls: 65.00
Posts: 1
Reputation: 0
#1
Got a logitech controller that worked 100% in DS1. For DS2... absolute trash. No way to jump, no way to move camera, attacks are bound to an analog stick... Unplayable, in other words.

I can't switch controls. I don't know if this is a problem with the PC Port or just me. But all the controls are mapped to mouse/keyboard settings, and changing them doesn't affect the controller at all.

I tried using Joytokey, and that works GREAT... except that I can't figure out how to TURN OFF the controller's default settings. By which I mean I hit a button, it does what I want AND it does something else too. Like hitting an analog stick right makes me look right, BUT ALSO makes me attack.

I tried using one of the weirdo xbox360 controller emulators, but I don't know if it's incompatible or if I'm an idiot. It didn't do a thing except turn a bunch of in-game colors blue.

So... I'm just gonna have to (really disappointingly) request a refund and just give up on this game I'm psyched to play. Unless I can find some help somewhere. I emailed the Bandai Namco support, but looking at their website I have zero confidence in their ability to fix this.

Thanks!