2
#11
+1 for the bug. Will I lose 10h gameplay for this? D:


edit: found solution! The giveme2entitlements.exe seems to have fixed it!

Edited by nagi_, 16 June 2010 - 12:58 AM.

#12
Has anyone found a sure fire fix for this? Any official response from like EA or Bioware?
#13
Giveme2entitlements hasn't fixed it for me, also having this problem.



Anyone got any ideas?
#14
+1 for a fix. I don't have any saves from before the Zaeed mission. :-(

EDIT: HA! FIXED! 

This seems to happen if you let someone else use your computer, log in with their acccount. and install DLC for which you are not authorized so they could use it. When you switch it back to your account, initially the only side effect is that it complains you're not authorized, but otherwise it seems like no big deal. Then this happens. If you delete or move the appropriate folders from C:\\Program Files (x86)\\Mass Effect 2\\BioGame\\DLC (this takes a little guesswork) the saves work again.

If your PITA friend wants to mess with your stuff again, tell him/her to find new friends.  :devil:

Hope this helps.

EDIT X2: IAMRandommer's below is probably better. Note the directory mentioned in that post is if yours is the Steam version, while mine is if yours is not. (Obviously.)

Edited by Honorable Reverend, 23 September 2010 - 03:05 AM.

#15
Sorted it, I deleted the BioPersistentEntitlementCache.ini



Find your copy in



C:\\Users\\(you)\\Documents\\BioWare\\Mass Effect 2\\BIOGame\\Config



Then deleted all the DLC out of the DLC folder



Found at



C:\\Program Files\\Steam\\steamapps\\common\\mass effect 2\\BioGame\\DLC



Then re-installed all the DLC and ran the game.



Then it worked :D
#16
I had this same problem with Arrival. Turns out if you have some DLC in there that you didn't register, it causes that. Doing what IAmRandommer said fixes it though I didn't have to delete the .ini like he did.
#17
PHEWW!!!!! Thank you guys a million times over! You just saved me 41 hours of replay :0

For some reason when I DLed patch 1.02 the Terminus armor dlc showed up. I thought it was a freebie perhaps, so I installed it. But obviously it wasn't authorized.

All I did was delete the unauthorized folder and logged into EA in-game.. fired up the previously moot save game.. and presto!! I'm back in business :D

Thank YOU ALL d(°û°)b
#18
Screw this, nothing works for me, because I have an unregistered version of the DLC, cause I bought my game used and didn't wanted to buy me a cerberus online whatever. Is there any other way, how to fix this?