I keep getting this message after hitting play on the first menu. It starts happening after the date check and then I can never get past this. I've tried reinstalling the game.

I downloaded the game from Direct to Drive.
Yeah, same problem here, I just installed all my bonus content and I'm waiting to start. I also downloaded from D2D.

Edited by GalacticTornado, 26 January 2010 - 09:08 PM.

exact same thing is happening to me
ditto. Is it the bonus content?
Nope, not the bonus content. I have not added that yet and I am having the same problem. Downloaded from direct2drive... Also tried running and setting up the configuration utility with no change. Running Win 7 x64
Does D2D offer the DLC through their site somehow?

 I know that sounds silly :-/ 

But i have had issues with patches for games i purchased from them in the past.
 They only patches that would work had to come from D2D

 I wouldn't think that would be the case with ME2 .. but just a thought.
The first time I installed I went ahead and installed all the DLC stuff first and got the error.
The second time I tried running it with just the core install and I still got the error. This seems to be a problem unique to the digital download version.

Edited by Vendrac, 26 January 2010 - 09:19 PM.

Same story here. Got the game from D2D. Downloaded. Installed ok. but couldn't play. tried the bonus content which installed fine. but still can't play.

awc.dll I hate you.
Does everybody else have the Digital Deluxe Edition or do some have the standard? I'm just wondering if its a DDE-only issue or not. Also, I'm running Windows 7 x64.