Discuss Divinity Original Sin, as well as comments posted to our Divinity Original Sin Wiki and Divinity Original Sin 2 Wiki
 7
 
I hope the dev team received a mountain of negative feedback on this part. If I wanted to play a puzzle game, why did I buy an RPG? The doll encounter is atrocious, tedious, repetitive, and pointless. If I've reached this point, I want to finish the game, and which brilliant mastermind thought he was so brilliant to come up with this nonsense? A total waste of time. If you want to design a difficult encounter, stick with your original game mechanics. Don't turn to silly gimmicks. Don't add this part to another one of your games, Larian Studios.
The first time around I had a very frustrating time and spent an hour before giving up. The second time I used Chameleon cloak on Sebile (the best mover in my group) separated her from the group to focus solely on pulling the levers. I sent her down the left staircase where three of the five levers are. Managed to pull the first lever in the first turn, the second two in the next turn by adding AP through adrenaline and flesh sacrifice. Then on the next turn I used Phoenix flight to cross over to the right side, pulled one lever then the last. I ended up encountering about six moppets in all and avoided getting turned into a cow. Hope this helps.
Probably irrelevant for most playthroughs, but if you complete the Path of Blood you get permanent angel wings with the flight ability unlocked. Additionally, you also glow as though you were always blessed.
*Path of Blood as in the purity test, not simply completing it with the alternative route.
I got tired of the gimmicky s**t, and just had a character sneak around out of combat while the puppets were frozen in combat with my party.
So I forgot to grab the scroll and am currently in the stature room. The door is locked, cannot be damaged, and I cannot use Sebille to jump through the window. Anyone know how I can get back out of the room??

I have the amulet on and failed the purity test. I would just reload but I was overwriting my saves (very stupid on my part) and would have to go back ~4 hours.
waypoints, you can still teleport to them
Ok! Now I am in the room with a full amulet and the scroll. I put the amulet in and read the scroll. Nothing happens. I see others have had this same problem. Any updates on a fix? Ive tried reloading it a couple of times, dropped the items and picked them back up, tried it with all 4 characters, but nothing has worked. Any other ideas?
hire a mercenary and let do him the purity test.
Played through on PS4 DE and this all worked as it’s supposed to. Each of my characters hit a puppet for 500+ magic armor damage then Source Vampirismed them and they died in a single round and stayed dead. About to finish my first play though and looking forward to starting over immediately at a harder level, which makes me think it’s a pretty good game.
Split your team in 4 independant characters : Send 3 to left, 1 to right, and activate the levers without taking care of the puppets
If anyone is having issues with their blood not staying Blessed the entire time (e.g. if you followed picture, the blood trail became unblessed once it crossed with the blessed fire), then use Raining Blood and cover the entire pathway with Blood and bless it.
I just let my blood run through unblessed and blessed it after
"To loot the ornate chest below next to the pipes, you can use Telekinesis to move a Teleporter Pyramid through the barrier"
Does not work for me.
It should read as "you can throw a Teleporter Pyramid through the barrier and use Telekinesis"